Submissions are verified against Village utility account records.
All systems operational
Power - Max Generation Alert
Resolved
Operational
Started over 3 years agoDecember 24, 2022Lasted about 3 hours12:453:15 AMUTC
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Monitoring
UTC
Monitoring
UTC
Alert relief in place. Monitoring status.
Identified
UTC
Identified
UTC
Max generation alert due to demand. Please reduce power consumption. Additional details on what this means can be found here: https://merrillanwi.gov/2022/12/23/power-generation-alert/