Bunting Ln Powerline Maintenance
Scheduled for October 02, 2025 at 1:00 PM – 5:00 PM
Affects
Electric Utility
Under maintenance from 1:00 PM to 5:00 PM
- Completed October 02, 2025 at 5:00 PM
- Completed - October 02, 2025 at 5:00 PM- Maintenance has completed successfully 
 
- In progress October 02, 2025 at 1:00 PM
- In progress - October 02, 2025 at 1:00 PM- Maintenance is now in progress 
 
- Planned October 02, 2025 at 1:00 PM
- Planned - October 02, 2025 at 1:00 PM- We are planning for a scheduled maintenance during that time.