Village of Merrillan - Electric Outage - Partial โ€“ Incident details

Village of Merrillan | Utility Status
๐Ÿ“ฒ Want instant utility alerts? Click here to Subscribe via Email
Submissions are verified against Village utility account records.

All systems operational

Electric Outage - Partial

Resolved
Partial outage 45 %
Started about 1 month agoLasted about 5 hours

Affected

Electric Utility

Partial outage from 12:53 PM to 6:01 PM

Water Utility

Operational from 12:53 PM to 6:01 PM

Sewer

Operational from 12:53 PM to 6:01 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    All outages resolved at this moment. We are currently monitoring for any additional outages.

  • Update
    Update

    We are continuing to work on a fix for this incident at Oakwood. Center St is resolved.

  • Update
    Update

    We are continuing to work on a fix for this incident. First outage from Center St should be resolved soon. New line down on Oakwood Pl to address.

  • Identified
    Identified

    We are continuing to work on a fix for this incident. Center St line down.

  • Investigating
    Investigating

    We are investigating a partial electric outage within the Village.