Submissions are verified against Village utility account records.
All systems operational
Electric Outage - Partial
Resolved
Partial outage 50 %
Started 7 days agoJuly 08, 2026Lasted about 2 hours11:32 PMJuly 09, 20261:14 AMUTC
Affected
Electric Utility
Partial outage from 11:32 PM to 1:14 AM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Identified
UTC
Identified
UTC
We are investigating a partial electric outage within the Village. Line down on Wisconsin St. Remaining customers will be without power for staff safety once repairs begin shortly.