Village of Merrillan - Electric Outage - Degraded – Incident details

All systems operational

Electric Outage - Degraded

Resolved
Operational
Started 29 days agoLasted about 6 hours

Affected

Electric Utility

Major outage from 5:57 AM to 11:36 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved. See attachment for details.

    Power Outage - March 3-4 2025.pdf

  • Update
    Update

    An issue with our primary lines has been identified, Fixes are in progress, but unfortunately there is still no time available for resolution yet.

  • Identified
    Identified

    We are investigating an electric issue within the Village.