Village of Merrillan - Electric Outage - Degraded – Incident details

All systems operational

Electric Outage - Degraded

Resolved
Degraded performance
Started 17 days agoLasted about 2 hours

Affected

Electric Utility

Degraded performance from 8:06 AM to 10:07 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    Issue identified, tree on line - checking additional locations.

  • Investigating
    Investigating

    We are investigating an electric issue within the Village. Low voltage detected on phases A&C at Lower Lake Hydro.