Village of Merrillan - Electric Outage - Partial – Incident details
Village of Merrillan
| Utility Status
VILLAGE HOME
⚠️ REPORT ISSUE / MAP
📲 Want instant utility alerts?
Click here to Subscribe via Email
Submissions are verified against Village utility account records.
Get updates
Email
Webhook
RSS
Atom
Get updates
All systems operational
Electric Outage - Partial
Resolved
Partial outage
50 %
Started 12 months ago
Lasted about 1 hour
Affected
Electric Utility
Partial outage from 2:45 AM to 3:37 AM
Updates
Resolved
June 05, 2025 at 3:37 AM
Resolved
June 05, 2025 at 3:37 AM
This incident has been resolved.
Identified
June 05, 2025 at 2:45 AM
Identified
June 05, 2025 at 2:45 AM
Temporary cut on S Hayden St to repair arcing line. We are investigating a partial electric outage within the Village.