Village of Merrillan - Electric Outage - Partial – Incident details

Village of Merrillan | Utility Status
📲 Want instant utility alerts? Click here to Subscribe via Email
Submissions are verified against Village utility account records.

All systems operational

Electric Outage - Partial

Resolved
Partial outage
Started 9 days agoLasted about 2 hours

Affected

Electric Utility

Partial outage from 11:36 PM to 12:04 AM, Operational from 12:04 AM to 1:22 AM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Monitoring
    UTC
    Monitoring

    Substation Update: Fuse Replaced, System Under Active Monitoring

    Heavy electrical load caused a fuse to blow at the local substation earlier today. Crews have replaced the fuse, and our team is actively monitoring the system to ensure the fix holds under current conditions.

    With extreme heat, heavy air conditioning use, and peak evening energy demands straining the local grid, the system remains under high pressure. To help keep power stable and prevent another outage while we monitor performance, please minimize unnecessary electricity use during these peak hours.

  • Investigating
    UTC
    Investigating

    We are investigating a partial electric outage within the Village.