Village of Merrillan - Power Outage - Blackout – Incident details

All systems operational

Power Outage - Blackout

Resolved
Partial outage
Started 4 months agoLasted less than a minute

Affected

Updates
  • Resolved
    Update

    Major storms rolled through the area resulting in some trees down, including one on the feeder line from Jackson Electric. Additional restoration was necessary on their end resulting in an extended outage which was restored at approximately 11:20 PM CST. The Village itself did not have any major damage, but did have some trees on lines on Bunting Ln/Beach Dr which were quickly removed.

  • Resolved
    Resolved

    The Village is currently without power. We are looking into the matter and/or staff is working on the issue including other service providers that feed the Village. Outage cause could be within the Village, through Jackson Electric, further down the line, or another issue. We will update as soon as possible. If you are in need of medical attention as a result of the power outage and it is an emergency, please call 911.