Village of Merrillan - Power Outage - Partial/Intermittent – Incident details

All systems operational

Power Outage - Partial/Intermittent

Resolved
Degraded performance
Started 7 months agoLasted about 3 hours

Affected

Updates
  • Resolved
    Update

    Lower Lake - Tree on power line from storm.

  • Resolved
    Resolved

    The Village is experiencing power outages in areas. We are looking into the matter and/or staff is working on the issue including other service providers that feed the Village. Outage cause could be within the Village, through Jackson Electric, further down the line, or another issue. We will update as soon as possible. If you are in need of medical attention as a result of the power outage and it is an emergency, please call 911.