Village of Merrillan - Power - Max Generation Alert – Incident details

All systems operational

Power - Max Generation Alert

Resolved
Operational
Started about 1 year agoLasted about 21 hours

Affected

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    Begins 6/28 @ 2300/11PM - Max Generation Alert - Please reduce power consumption. Additional details on what this means can be found here: https://merrillanwi.gov/maxgen