Village of Merrillan - Power Outage - Partial – Incident details

All systems operational

Power Outage - Partial

Resolved
Partial outage
Started over 1 year agoLasted about 15 hours

Affected

Updates
  • Resolved
    Resolved

    Power has been restored to all residents. If any other issues come up please let us know.

  • Identified
    Identified

    Crews are still working to fix power outages. Heavy snow and wind along with road conditions are making the process longer. Please be patient. Thank you.

  • Investigating
    Update

    We are continuing to investigate this issue.

  • Investigating
    Investigating

    Bunting Lane and Lower Lake outage. Additional power outages may occur.