Village of Merrillan - Power Outage - Blackout – Incident details

All systems operational

Power Outage - Blackout

Resolved
Partial outage
Started over 1 year agoLasted about 22 hours

Affected

Updates
  • Resolved
    Update

    Outage on Jackson Electric’s end.

  • Resolved
    Resolved

    The Village as a whole is currently without power. We are looking into the matte and/or staff is working on the issue including other service providers that feed the Village. Outage cause could be within the Village, through Jackson Electric, or further down the line.