Village of Merrillan - Electric Outage - Partial – Incident details

All systems operational

Electric Outage - Partial

Resolved
Operational
Started 2 months agoLasted about 2 hours

Affected

Electric Utility

Operational from 11:59 PM to 1:41 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We are investigating a partial electric outage within the Village.