Village of Merrillan - Electric Line Maintenance - Begins 7/11 @9am – Incident details

All systems operational

Electric Line Maintenance - Begins 7/11 @9am

Resolved
Operational
Started 2 months agoLasted about 3 hours

Affected

Electric Utility

Operational from 2:00 PM to 5:00 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    Electric line maintenance will be underway that will affect Bunting Ln and East Pearl St residents from approximately 9am-10am CST. The power will be out for approximately 30-60 minutes if everything goes smooth. The purpose of this maintenance is to address a line issue in a tough-to-reach area that has been causing increased outages recently. Please plan accordingly.